What software do I need to use USPTO’s fillable PDF forms?


Adobe Acrobat Reader 7.0.8 or 7.0.9 ONLY is required to use the EFS fillable forms. Other USPTO fillable forms not designed for EFS can be filled and saved only with Adobe Acrobat Professional, version 6 or higher.


USPTO FAQ - Questions and Answers (07JAN2007)